I don't know if this is a bug. Maybe it's just my operating system (ubuntu 10.10), computer, or browser(Mozilla 3).

As of yesterday, I can write answers very hard. I noticed that before, the latex text preview didn't get compiled until I stopped writing for a few seconds. I think that from today the compilation takes place as I write, and that makes writing go very slow after the text becomes longer than a few paragraphs, and I have five or more formulas. Has anything been changed in the system, or it's just my computer doing something wrong?

Has anyone encountered something similar?

[edit] Don't know if it is a good idea, and I am not in the place to say it, but in MathOverflow there is an option to disable math preview. Maybe this could be implemented here also, but if I'm the only one who has problems with this issue, then it is ok as it is.

share
    
(comments removed) since they all referred to an earlier iteration of this feature. There may still be issues, but I wanted to be sure we're all talking about the current version and not one that only exists in history. –  Jeff Atwood Jul 22 '11 at 6:37
    
@Jeff It would be very helpful to let us know precisely when changes like this are rolled out. Knowing such allows us to provide better and more timely feedback. Geoff's answer below said that the fix was going to be deployed a month ago, but it appears to have been deployed only recently. Is the current version supposed to be the ultimate fix? When was it deployed? –  Bill Dubuque Jul 27 '11 at 15:19
    
It would be great if the instant preview feature could be turned off (the formulas would compile when I stopped writing), it is still a very unpleasant experience for me, regardless of the browser I use, on an up-to-date Arch Linux notebook. –  David Čepelík Jan 23 at 10:05
add comment

3 Answers

up vote 17 down vote accepted

We are working on a fix for the speed during render that should satisfy both the speed and instant preview concerns. It should be deployed tonight.

share
    
+1 The behavior is, indeed, markedly better than it was yesterday. I still notice the slowing down, but either I am in a better mood today, or it no longer becomes infuriatingly slow. I haven't needed to type a long answer with a lot of formulas today, yet. –  Jyrki Lahtonen Jun 24 '11 at 12:15
    
I wrote a longer question, and it is still slow, from a point on. Anyway, it's acceptable. –  Beni Bogosel Jun 24 '11 at 18:20
    
I'm still faced with the very long delays; it seems like after a certain point the instant preview disengages, but it took far too long to do so when I was writing this answer. I had waits of 90 seconds or more at some stages, when I was one or one and a half lines ahead of what was appearing on the screen. –  Arturo Magidin Jun 24 '11 at 20:38
1  
Your answer just became the new test case for rendering mathjax quickly. There are still some improvements in the pipeline. –  Geoff Dalgas Jun 25 '11 at 3:25
9  
@Geoff: As Arturo points out below it still is incredibly slow (I'm basically unable to use the answer field for writing answers involving more than a few lines and use a text editor instead). This is extremely inconvenient. Is there any chance to revert to the previous state without instantaneous compilation or provide an option to turn this thing off? I see little point to it, in fact. –  t.b. Jun 30 '11 at 21:47
5  
@Geoff It's still very slow, almost unusably slow. If you cannot speed it up, then why not settle for some compromise, e.g. let the user force rerendering by issuing some easily typed command. –  Bill Dubuque Jul 8 '11 at 21:25
1  
The problem is when there's a lot of mathematical equations in the answer. As someone else has pointed out, it means having to use a text editor to write the answer out in, and pasting it into the answer pane when finished. The solution would appear to have a preview button, istead of the answer being continually updated. –  user10389 Jul 24 '11 at 12:36
4  
Thanks for your patience on this issue. We finally have a decent plugin system for our markdown editor which includes MathJax rendering. Please leave your feedback and let us know how it's working. –  Geoff Dalgas Jul 27 '11 at 4:51
    
@Geoff, I wonder whether this new plugin could have anything to do with the difficulties I've started experiencing with Safari on m.se. Repeatedly it hangs and tells me some script is not stopping and asks me whether to continue or stop. –  Gerry Myerson Jul 27 '11 at 5:43
    
@Geoff: Thanks for your efforts. It's much better now, but I think there still is a quite annoying lag between typing and the update of the display. It frequently happens to me that I have to wait a few seconds (up to around ten) until the display updates to the point where I'm typing. –  t.b. Jul 27 '11 at 13:36
1  
it doesn't seem to have improved very much, still extremely slow here (on a reasonably quick computer). It would be a real improvement if there was an option to turn prerendering off. –  mt_ Jul 31 '11 at 12:04
    
has this fix happened yet? I'm still experiencing 2 chars/second as soon as I type a first dolar sign –  Tobias Kienzler Jan 3 '12 at 11:42
    
@TobiasKienzler what are your system specs and which browser / version are you using? –  Geoff Dalgas Jan 3 '12 at 15:44
1  
@GeofDalgas: Intel Atom 330 @ 1.6GHz, 2GB RAM, Win7, Firefox 3.6.3 (I'm no admin here unfortunately so please don't ask me to update...). I pinned part of the problem down to greasemonkey, but even with that turned off it's still a bit slow. Maybe the TeX rendering could be slightly delayed? –  Tobias Kienzler Jan 4 '12 at 7:59
    
@tobias Firefox 3.6 is quite ancient by now, and you'll certainly see far better JavaScript perf if you update Firefox. –  Jeff Atwood Jan 23 '12 at 17:57
show 1 more comment

I'm still facing very slow response, and now I'm facing it at home as well as at work. At work I run Firefox 3.6.18 on Ubuntu 10.04.2; at home I'm running Firefox 5 on Windows XP. The behavior at home is markedly worse now. Again, I'm two or three lines ahead when typing, and I have to wait about one to one a half minutes for it to catch up.

Update, Jun 30 Still annoyingly slow once the answer goes beyond a couple of paragraphs.

Update, Jul 8 Still the same.

Update, Jul 20 I am not certain if things are as bad as before, but writing long answers is still very slow after a certain length. Editing is "dangerous" and I have lost quite some text when foolishly tried to edit within the page - my browser simply hanged and I had to kill it.

share
    
Have you tried using Chrome? I don't mean that as a suggestion to switch browsers; rather, I'm curious to what extent the issue does or does not have anything to do with some aspect of how Firefox interacts with MathJax. –  Isaac Jun 27 '11 at 0:02
1  
@Isaac: No, I've never used Chrome. Don't even have it downloaded. –  Arturo Magidin Jun 27 '11 at 2:06
    
@Isaac I use Chrome. It doesn't quite resolve the problem. –  Grigory M Jul 1 '11 at 9:52
    
I'm sad to say that with relatively long answers, it still is too slow for comfort. Tricks like erasing a sentence by selecting it with a mouse as opposed to letting a finger rest on the backspace/delete key do help. Is it possible to add a condition that the TeX reinterpreter/renderer/whatever will not start unless at least 20 characters have been added/removed and/or a timer has expired. Would it work, if it were linked to 'draft save'? Or a different behavior according to wheteher characters were added between dollar sign or not? –  Jyrki Lahtonen Jul 3 '11 at 9:42
2  
Arturo: I added an update to your answer, in the hope of attracting some attention because it is still not working right for me. I hope you don't mind. –  t.b. Jul 8 '11 at 16:10
    
@Theo: Thanks, when writing some long answers lately I was really horrified by this bug. –  Asaf Karagila Jul 8 '11 at 18:54
3  
@Theo I too find it unusably slow. –  Bill Dubuque Jul 8 '11 at 19:59
    
@Theo: Not at all; thanks. Right now I'm not on the site as much as usual, and the only answers I've written for the past week have been short-ish, so I couldn't speak from personal experience. I am sad to hear it's still going on. –  Arturo Magidin Jul 8 '11 at 20:10
    
As another datapoint: it's very slow, almost unusable on my computer (Firefox 3.6.18/Ubuntu 10.10) even with short answers. I think there should simply be an option to turn preview rendering off -- that would presumably be simple to implement for the SE team and would solve the problem to a large degree. –  mt_ Jul 24 '11 at 21:28
1  
For a little while there seemed to be an option to turn off the whole previewer, on the bottom left corner of the edit box; seems to be gone now. –  Arturo Magidin Jul 24 '11 at 21:37
add comment

Here are a couple of bookmarklets (bookmarks in the bookmark bar) that disable and enable the auto-rendering of in-process edits, as mentioned by Jack Schmidt in answer to this feature request.

For those who don't feel comfortable creating or editing bookmarks in the bookmark bar, there are draggable links here. Drag the links for "rendering off" and "rendering on" to your browsers bookmark bar.

For those who know how to create and edit bookmarks in the bookmark bar here is the code for each.

disable edit rendering:

javascript:(function(){MathJax.Hub.queue.pending=1;})();

enable edit rendering:

javascript:(function(){MathJax.Hub.queue.pending=0;MathJax.Hub.Queue(["Typeset",MathJax.Hub,"wmd-preview"]);})();
share
    
I will say it again: you should receive the elusive Hacker badge for all these scripts. –  Asaf Karagila May 9 '12 at 16:55
    
I think you only need javascript:XX; instead of javascript:(function(){XX;})(); –  user2468 May 9 '12 at 17:01
    
@JD: Thanks. I will try that. –  robjohn May 9 '12 at 19:59
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .